GMLscripts.com

Discuss and collaborate on GML scripts
Invert

You are not logged in.

#1 2007-10-09 04:31:24

xot
Administrator
Registered: 2007-08-18
Posts: 1,201

Cookie Problems

Some users may find a time that they are unable to Login/Logout successfully. This is a known issue. I'm still trying to figure out what exactly is causing the problem. It is related in some way to Cookies and Subdomains. If you are accessing the forum from gmljoint.com or www.gmljoint.com, add or remove the www. portion of the URL and try again. If that doesn't work, clear your Cookies for this website and try again.

The developers of punBB do not yet have an answer to this problem, they apparently have never experienced it themselves. Nevertheless, some administrators of other punBB forums report the same issue. What is odd is that it is such an intermittent problem. You may be able to use the forum for several sessions without issue, then suddenly the problem will pop up. As I said, I will continue to look for a solution.

Sorry for any inconvenience.


Abusing forum power since 1986.

Offline

#2 2007-10-13 09:59:47

xot
Administrator
Registered: 2007-08-18
Posts: 1,201

Re: Cookie Problems

The same cookie issue that effects login/logout seems to effect the "Mark all topics as read" function too. That kinda stinks.


Abusing forum power since 1986.

Offline

#3 2008-08-30 03:15:32

xot
Administrator
Registered: 2007-08-18
Posts: 1,201

Re: Cookie Problems

Just a little update. The problem still persists, but I've found another thing to try if you can't seem to log out (or in, possibly). When you attempt log out, you are taken to a page that has a brief message about being logged out, and a second or so later you are redirected back to the forum index, where you see you are not logged out at all. If that happens to you, try again, but the moment you see the brief message (and before you are redirected), refresh your browser (F5). It looks like a caching issue might be the cause of the problem, and a quick refresh at the right time seems to correct it.


Abusing forum power since 1986.

Offline

#4 2010-02-24 17:43:40

brac37
Member
Registered: 2010-02-12
Posts: 18

Re: Cookie Problems

I had a problem signing up with chrome. The error message was that the anti-bot text was incorrect. I used firefox to sign up.

Offline

#5 2010-02-25 00:52:23

xot
Administrator
Registered: 2007-08-18
Posts: 1,201

Re: Cookie Problems

I see what you mean. That's annoying. I'll look into it.

EDIT

The first time I tried to register using Chrome it failed. Next try it worked. After doing some checks, I found a problem with the template processing for the forum. A mod was not correctly preserved when I last upgraded the forum software. That was causing a few XHTML errors which might have confused Chrome. I fixed the problem but I don't know if it was the problem. It's difficult to test because of IP flood control measures that can't be easily disabled.

Last edited by xot (2010-02-25 03:18:05)


Abusing forum power since 1986.

Offline

Board footer

Powered by FluxBB