GMLscripts.com

Discuss and collaborate on GML scripts
Invert

You are not logged in.

#1 2018-07-26 11:22:39

xot
Administrator
Registered: 2007-08-18
Posts: 1,188

Not-so-minor SSL Update

blogicon-20180726.gifEarlier in the month I posted about minor updates coming to the site. A recent one was pretty major. I've transitioned the site to SSL and hopefully I didn't screw things up too badly. That means the site and forums should be accessed using https:// protocol. This secures your connection from being snooped by baddies and makes Chrome (and future browsers) less likely to alarm visitors with dire warnings of mischief.

The transition required a lot of gentle massaging to get everything working correctly. If something seems amiss, please let me know here or via Twitter.


Abusing forum power since 1986.

Offline

#2 2018-09-12 20:57:42

idealcastle
Member
Registered: 2018-09-12
Posts: 9

Re: Not-so-minor SSL Update

I notice the site is still running HTTP. If you're using Apache you can use an auto-forwarding redirect over to HTTPS.

Something like this:

RewriteEngine On 
RewriteCond %{HTTPS} !=on 
RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]

Offline

#3 2018-09-13 03:44:42

xot
Administrator
Registered: 2007-08-18
Posts: 1,188

Re: Not-so-minor SSL Update

Trying to get the site to redirect to HTTPS has been nightmare. No matter what I tried I'd get a redirection loop, even if I eliminated every other rule in case there was some conflict. Same thing with this suggestion.

However, it prodded me to explore this more deeply and it looks like I neglected a server setting which is what was apparently causing the conflict. I was "doing it wrong" trying to get this going with .htaccess. I think it should be working properly now.

Thanks.


Abusing forum power since 1986.

Offline

#4 2018-09-13 23:07:59

idealcastle
Member
Registered: 2018-09-12
Posts: 9

Re: Not-so-minor SSL Update

xot wrote:

Trying to get the site to redirect to HTTPS has been nightmare. No matter what I tried I'd get a redirection loop, even if I eliminated every other rule in case there was some conflict. Same thing with this suggestion.

However, it prodded me to explore this more deeply and it looks like I neglected a server setting which is what was apparently causing the conflict. I was "doing it wrong" trying to get this going with .htaccess. I think it should be working properly now.

Thanks.


Awesome looks like its working on my end!

Offline

#5 2018-11-01 10:05:04

Rasnake
Member
Registered: 2018-10-25
Posts: 1

Re: Not-so-minor SSL Update

How did you manage to do it in the end, Xot?

Offline

#6 2018-11-01 13:33:25

xot
Administrator
Registered: 2007-08-18
Posts: 1,188

Re: Not-so-minor SSL Update

It was just a server control panel setting I didn't notice.


Abusing forum power since 1986.

Offline

Board footer

Powered by FluxBB